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Creating PDF forms 

Previously, in Designing your PDF Forms, we looked at PDF Form layout. Let’s now look at actually creating a PDF form. We’ll focus on the addition of form fields to the page and subsequent field labeling—the addition of supporting text and graphics to the form is covered previously.

Adding form fields

A series of form fields can be added to the page, depending on the type of form you want to create. Typically a mix of form fields will make up your finished form design.

Fields are created from the Form toolbar or via Insert>Form Field. You assign an internal unique name to each field and then set a variety of properties. Each form field has its own set of Form Field Properties which can be modified to suit your form implementation.

	
The Form toolbar is turned off by default. Display it by going to View>Toolbars>Form.


	
Form field names can contain “+”, “-”, “_”, but no special characters.




Let’s look at each Form field in turn.
	
Icon 
	
Form Field Name 
	
When to use? 

	
 
	
Button*

	
Use when specifying an action that can be triggered by a button click (example).


	
 
	
Submit button*

	
Use when sending the form recipient’s completed form data to Serif Web Resources or to your own Web server. A Form Submit Wizard is activated to enable quick and easy button setup.


	
 
	
Reset button*

	
Use when you want to add a button to clear all form fields of data (often complements the above Submit button).


	
 
	
Print button*

	
Use when you want to add a print button to your form.


	
 
	
Check Box

	
Ideal when you want to multiply select a series of options displayed side by side. A good alternative to a Combo Box or List box if space allows (example).


	
 
	
Text Field

	
Use for adding text, numbers or a mixture of both (example).


	
 
	
Combo Box

	
For selection from a scrollable list of items in a drop-down menu where only one item can be selected (example). The box also allows data entry to be input into this box type. Smaller than a List Box.


	
 
	
List Box

	
For selection from a scrollable list of items; supports multiple selection (example) and advanced actions on selection of menu items.


	
 
	
Radio Button

	
Good for selection of a single mutually exclusive item from a grouped subset of choices (example).


	
 
	
Signature

	
Used for the digital signing of secure documents.


	
 
	
Sound Clip¨

	
Use to insert a PDF sound clip (.wav, .wave, .aif, .aiff, .aifc, .mp3).


	
 
	
Movie Clip¨

	
Use to insert a PDF movie clip (.avi).


	
 
	
Form Field Properties¨

	
Use to view and edit the properties of the form fields.


	
 
	
Tab Order¨

	
Use to check or change the tab order of the fields.





* This button shares a drop down menu with other buttons marked with an asterisk. The button type previously chosen will always be displayed on the Form toolbar.

¨ These items are found on the Form toolbar.

Buttons/Submit button

A whole range of buttons of varying design and function can be created. Some examples include:

	
Advanced – Displays menu options that are only applicable for advanced uses.


	
Show All – Displays all menu options.


	
Next page – Jumps the form recipient to the next page.


	
Open – Opens a file or web link.


	
Import – Imports form data.


	
Reset – Clears all form data.




The  button is specifically designed to run a Form Submit Wizard. This ensures that configuration of web-ready forms is made that much easier.

To create a button:

	
Select the  Button option from the Form toolbar.


	
Move your  cursor to the location for your button and click once.


	
Right-click on the button and choose Form Field Properties from the drop-down menu.


	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Go to the Options tab, and enter a new Caption name (the text that appears on the button).


	
Go to the Actions tab and click the Add button.


	
In the resulting Action dialog, select an Event that will be used to trigger the action.


	
Choose an Action from the drop-down menu.


	
Change the properties displayed under the selected action. The options shown change depending to the action selected.




Check box

Check boxes are boxes containing a simple check, cross, or other symbol. The form recipient clicks once to select or deselect the box.

Example:

Would you like to be notified of any upcoming events in the near future? 

To create a check box:

	
Select the  Check Box option from the Form toolbar.


	
Move your  cursor to the location for your box and click once.


	
Right-click on the box and choose Form Field Properties from the drop-down menu.


	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Go to the Options tab, and choose a Style for the check box—a check or cross is the most common—and whether the box is checked by default.




Text field

Text fields are used for entering input, either textual or numerical. Validation can be performed on any text field.

Example:

Name, Address, Cash amounts, Phone Numbers.

For large text fields remember to check the Multiline check box to allow line breaking.

To create a text field:

	
Select the  Text Field option from the Form toolbar.


	
Move your  cursor to the location you want to place the text field and click once.


	
Right-click on the text field and choose Form Field Properties from the drop-down menu.




	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Go to the Options tab to:


	
	
change the text alignment of the entered recipient data.


	
set some Default Text, if necessary.


	
restrict the length of data that can be input with Limit Length.


	
select Multiline, allowing text input to break across more than one line.


	
select Scrollable—this means a scroll bar is available for long text fields.


	
make the field mask input with asterisks by using Password.


	
use File select to allow form recipients to enter a filename. The file contents are used instead of direct text input in the text field.


	
apply Spell check. This enables spell checking on data input.





	
Go to the Format tab to set the format that the form recipient is able to input, i.e. None, Number, Date, Time or Custom.


	
Go to the Validate tab to run a simple (numeric only) or custom validation script. This checks that input is valid.


	
Go to the Calculate tab to perform any calculations on numeric fields only.


	
Click OK.


	
To change the text field into a numeric field, change the Format as: option in the Format tab to Number.


	
Don’t use numeric fields for telephone numbers. Use unformatted text fields instead.




Combo box

The Combo Box presents a list of menu items in a drop-down menu, and optionally allows the form recipient to enter their own items.

Example:
	
 
	
Click on drop down to expand Combo Box

	
 




To create a combo box:

	
Select the  Combo Box option from the Form toolbar.


	
Move your  cursor to the location for your Combo Box and click once.


	
Right-click on the combo box and choose Form Field Properties from the drop-down menu.




	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Go to the Options tab, type in an Item and click the Add button. The item is added to the Item list.


	
Keep adding each item that you want to the Item list.


	
If necessary, reorder any selected item in the list using the adjacent Up or Down button.


	
You can also:


	
	
Sort items alphabetically or numerically.


	
apply Check spelling. This enables spell checking on input.


	
Use selected list item as default.


	
make the Combo box Editable.


	
validate input on selection with Commit on Select.





	
Go to the Format tab to set the format that the form recipient is able to input, i.e. None, Number, Date, Time or Custom.


	
Go to the Validate tab to run a simple (numeric only) or custom validation script. This checks that input is valid.


	
Click the OK button.




List box

The List Box presents a list of items in a static box with scroll bar support. Multiple selection of items is supported.

You can also use Commit on Select to run JavaScript scripts when you select menu items. This is ideal when you want to display supporting pictures or sounds with your menu items.

For example, to select Beethoven, Mozart and Strauss, use Ctrl-click on the menu items:

 
To create a list box:

	
Select the  List Box op

tion from the Form toolbar.


	
Move your  cursor to the location for your List Box and click once.


	
Right-click on the list box and choose Form Field Properties from the drop-down menu.


	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Go to the Options tab, type in an Item and click the Add button. The item is added to the Item list.


	
Keep adding each item that you want to the Item list.


	
You can also:


	
	
Sort items alphabetically.


	
Use selected list item as default.


	
make the list box support Multiple selection.


	
validate selection or run JavaScript code immediately on item selection with Commit on Select.





	
Click the OK button.




Radio buttons

Radio buttons operate slightly differently to other form fields. To operate correctly, Radio buttons which are intended to be grouped, e.g. for Male/Female Gender selection, must both be configured to be a part of the same configurable Field Group. Field groups are set in Form Field Properties, General tab.

For example, in a field group called “group1″ you could include radio buttons as Yes/No options:

 
Alternatively, you could have another set of radio buttons, in a different field group (called “Gender”), which can determine the sex of the form recipient.

 
	
When placing radio buttons on the page you can leave them as unchecked (default) or change them to   checked with the Checked by default option on Form Field Properties (Options tab).




To create a radio button:

	
Select the  Radio Button icon from the Form toolbar.


	
Right-click on the radio button and choose Form Field Properties from the drop-down menu.


	
In the General tab, overwrite the current Name with a unique internal name. You can also choose several other optional settings (see General tab).


	
Add a Field Group that your grouping of radio buttons will share.


	
In the Options tab, choose a radio button Style. You can also:


	
	
Make the button Checked by default.





	
Click the OK button.




To create a digital signature field:

See Using Digital Signatures.

Using field labeling

For the form field types Check box, Text field, Combo box, List box, or Radio button, it doesn’t make much sense to add the form field to the page without some form of labeling. This indicates to the form recipient what the associated field relates to, e.g. a Radio button or Check box without an accompanying description is clearly pointless.

	
The Button form field has built-in labeling—it adopts the Caption field as its label.


	
For good form design, ensure that labeling is positioned consistently and is placed close enough to the form field to avoid confusion.




To apply labels:

	
Add your label as Artistic Text (see Using artistic text). This lets you apply standalone text, allowing greater flexibility.


	
Group the label and form field together.


	
Right-click and select Arrange>Align Objects from the drop-down menu. Choose a vertical or horizontal alignment option, and select a distribute objects option.




Form field properties

Form field properties control how the form field will operate when the form recipient enters their input. A series of tabs are arranged so that some tabs, e.g. General, Appearance, Options, or Actions, are common to all the form fields but others, such as Format, Validation and Calculations are only displayed for text fields and combo boxes.

Tabs frequently used include:

	
Options tab: To populate the contents of a combo box with item selections.


	
Actions tab: To submit a form select the “MouseUp” Event and “Submit a Form” action (for a button object only).


	
Format tab: To change a text field to a numeric field.




For a detailed breakdown of every form field see Form Field Properties.

To access Form Field Properties:

	
To view the properties do one of the following:


	
Right-click on a selected form field and choose Form Field Properties.


	
Double-click the form field.


	
Select the form field, and click the  button from the Form toolbar.




	
Click on one of several tabs for editing: General, Appearance, Options, Actions, Validate, or Calculate.


	
Click the OK or Cancel button to exit the dialog.




Publishing your PDF Form

	
Click  Publish PDF on the Standard toolbar.
 – or -

 Select Publish as PDF… from the File menu.




See Exporting PDF files for more information.

	
If you Publish as PDF using PDF/X-1 or PDF/X-1a compatibility, any PDF form fields present will be converted to graphics and will not be available. Choose an Acrobat option instead.
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